• Web sitemize destek olmak, Hazır Excel Dosyaları indirmek ve sitemizi reklamsız kullanmak için VIP Üyelik Satın alabilirsiniz.
    Hesabını VIP Üyeliğe Yükselt

Soru Belirli Koşula göre Parça Alma İşlemi

REKLAM

akwolpolin

Yeni Üye
Kullanıcı
Versiyon
  1. Excel 2010
Sürüm
  1. 64 bit
Dil
  1. Türkçe

Reputation:

Kart KoduÜrün AçıklamasıAna BirimAna Döviz
ASA.95.285.43285 J 43 - ORTA KAYIT 23,7MM (11874 PRF)ADEUR
KP01.10.00.02.01ALFABOND 002 - 1250*3200 KOMPOZİT - LİZ BRONZM2USD
ASA.90.193.03193 L 03 - KÖŞE TAKOZU - 25,90MM - SKY65ADEUR
SAA02.00.01.00SC-100 - KANAT BİNİ FİTİLİMTTL
TA02.16.11.30BİLEZİK 30 LUK - PARLAKADTL

Arkadaşlar Merhaba,

Bu şekilde on binlerce satırlık bir dosyam var.
Bu liste her gün değişiyor Kart kodları her zaman bu şekilde sıralı gelmiyor. Parça Al formülü tek başına işimi çözmüyor. Parça Al formülünü bir kurala Bağlamam Lazım.

Benim yapmak istediğim.

Kart kodunda;
"ASA" geçiyorsa Parça Al 6 Karakter
"KP" geçiyorsa Parça Al 4 Karakter
"SAA" geçiyorsa Parça Al 5 Karakter
"TA" geçiyorsa Parça Al 4 Karakter AL

Böyle bir formül yapmam lazım.

(Konu Biraz Acil)Şimdiden Teşekkürler.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

AhmetRasim

Forum Yönetimi
Yönetici
Site Yöneticisi
Versiyon
  1. Excel 2019
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

Merhabalar Sn. akwolpolin
-- Kart Kodu bilgisinin A sütununda olduğunu varsayılmıştır.
PHP:
=EĞER(EĞERSAY(A2;"ASA*")>0;PARÇAAL(A2;1;6);EĞER(EĞERSAY(A2;"KP*")>0;PARÇAAL(A2;1;4);EĞER(EĞERSAY(A2;"SAA*")>0;PARÇAAL(A2;1;5);EĞER(EĞERSAY(A2;"TA*")>0;PARÇAAL(A2;1;4);""))))
-- A2 hücresini kart bilgisinin olduğu hücre adresi ile değiştiriniz.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

akwolpolin

Yeni Üye
Kullanıcı
Versiyon
  1. Excel 2010
Sürüm
  1. 64 bit
Dil
  1. Türkçe

Reputation:

Merhabalar Sn. akwolpolin
-- Kart Kodu bilgisinin A sütununda olduğunu varsayılmıştır.
PHP:
=EĞER(EĞERSAY(A2;"ASA*")>0;PARÇAAL(A2;1;6);EĞER(EĞERSAY(A2;"KP*")>0;PARÇAAL(A2;1;4);EĞER(EĞERSAY(A2;"SAA*")>0;PARÇAAL(A2;1;5);EĞER(EĞERSAY(A2;"TA*")>0;PARÇAAL(A2;1;4);""))))
-- A2 hücresini kart bilgisinin olduğu hücre adresi ile değiştiriniz.
Çok Teşekkürler Ahmet Bey,

Peki Birleştir Formülü ile çarpma veya bölme işlemi yaptıra bilir miyim ?

Fiyat GrubuKart KoduÜrün AçıklamasıAna BirimAna DövizFiyat 1Döviz 2
A1ASA.01.02.0601.02.06 - DÜŞEY GRİYAJ FİTİLİMTEUR0,52*0,1402S.P. EUR*
0,1402​


Fiyat bir kolonuna " =BİRLEŞTİR(DÜŞEYARA(B:B;'Fiyat Listesi'!A:K;11;0);Q3;R3) " bu formülü yazıyorum
Çıkan Sonuç = 0,52*0,1402

Olmasını istediğim = 0,072904
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Ömer BARAN

Kurucu
Yönetici
Kurucu
Versiyon
  1. Excel 2013
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

Merhaba Sayın akwolpolin .
Sayın AhmetRasim şu an çevrimiçi değil.

Sorularınızı, cevabımın altındaki İMZA bölümünde yer alan açıklamalar (okuyunuz) doğrultusunda hazırlayacağınız
örnek belgeler üzerinden sorarsanız daha hızlı ve net sonuca ulaşmanız kolaylaşır.

Sorunuzu ve verilen cevabı incelemiş değilim ancak şunu belirteyim;
BİRLEŞTİR işlevi bir METİN işlevi ve sonucu da doğal olarak METİN.
BİRLEŞTİR formülü sonucunda matematiksel işlem yaptıramazsınız.

Yine de aşağıdaki gibi bir deneyin (konuyu incelemiş değilim sadece son mesajdaki durumla ilgili fikrimi yazıyorum) .
Mesajınızı fark ettiğinde, Sayın AhmetRasim konuyla ilgilenmeye devam edecektir mutlaka.

Kod:
=DÜŞEYARA(B:B;'Fiyat Listesi'!A:K;11;0)*R3

.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

akwolpolin

Yeni Üye
Kullanıcı
Versiyon
  1. Excel 2010
Sürüm
  1. 64 bit
Dil
  1. Türkçe

Reputation:

Merhaba Sayın akwolpolin .
Sayın AhmetRasim şu an çevrimiçi değil.

Sorularınızı, cevabımın altındaki İMZA bölümünde yer alan açıklamalar (okuyunuz) doğrultusunda hazırlayacağınız
örnek belgeler üzerinden sorarsanız daha hızlı ve net sonuca ulaşmanız kolaylaşır.

Sorunuzu ve verilen cevabı incelemiş değilim ancak şunu belirteyim;
BİRLEŞTİR işlevi bir METİN işlevi ve sonucu da doğal olarak METİN.
BİRLEŞTİR formülü sonucunda matematiksel işlem yaptıramazsınız.

Yine de aşağıdaki gibi bir deneyin (konuyu incelemiş değilim sadece son mesajdaki durumla ilgili fikrimi yazıyorum) .
Mesajınızı fark ettiğinde, Sayın AhmetRasim konuyla ilgilenmeye devam edecektir mutlaka.

Kod:
=DÜŞEYARA(B:B;'Fiyat Listesi'!A:K;11;0)*R3

.
ilginiz için teşekkürler,

şuan bu formülü kullanıyorum çalışıyor.

Aradaki çarpma işlemi ilk baştaki sorumun sonucunda değişkenlik gösteriyor bazen ÇARP bazen BÖL Bazen Topla Oluyor.

bu işleme göre matematiksel işlemi değişkene göre işlem yaptırmak istiyorum. aklıma ilk gelen birleştir formülü oldu o da dediğiniz gibi çalışmadı

Tekrar teşekkürler.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Ekli dosyalar

  • fiyat aktarım.xls
    180.5 KB · Görüntüleme: 3

Ömer BARAN

Kurucu
Yönetici
Kurucu
Versiyon
  1. Excel 2013
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

akwolpolin
-- İşlemin çarpma mı bölme mi, toplama mı olduğuna mutlaka koşula göre karar veriliyordur.
Belirttiğiniz formülü belgenizde göremedim. Matematiksel işlem formülünü koşula göre (hücre adresleri hayali)
=EĞER(A1="*";ÇARPIM(B1;C1);EĞER(A1="/";BÖLÜM(B1;C1);EĞER(A1="+";TOPLA(B1;C1);"")))
gibi bir mantıkla oluşturun.

-- Fiyat Listesi Sayfası L sütunundaki formül aşağıdaki gibi kısaltılabilir,
Dikkat ARA işlevinde ilk {....} arasındaki değerler metinse alfabetik, sayıysa küçükten büyüğe sıralanmalıdır.
Yani {"SA";"TA";"AS";"KP"} değil {"AS";"KP";"SA";"TA"} gibi.

C#:
=EĞERHATA(DÜŞEYARA(PARÇAAL(A2;1;ARA(SOLDAN(A2;2);{"AS";"KP";"SA";"TA"};{6;4;5;4}));Sabitler!A:C;3;0);"")

.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Üst