Sitemize Hoşgeldiniz

Türkiye'nin en geniş özeliklere sahip forumu olan ExcelDestek.Com üzerinde soru sorabilmek, daha önceki sorulan sorulara, açılan konulara cevap yazabilmek, puan kazanabilmek, kazandığınız puanlar ile dosya indirebilmek ve çok daha fazla özellikten yararlanabilmek için sitemize üye olunuz.
Hemen Üye Ol ya da Giriş Yap

Sorun Cevaplayalım

Excel'e dair sorularınızı sorun, cevaplayalım.

Çözümlenmiş Sorular

Kullanıcılarımızın sorularını ve sunduğumuz çözümleri inceleyin.

Destek Ekibimiz Sizlerle

Ücretli destek ve özel hizmet talep edebilirsiniz.

  • Web sitemizi "REKLAMSIZ" olarak ziyaret etmek ister misiniz?
    Gerek sitemize destek, gerekse de reklam görmeden sitemizde gezinmek isterseniz, HESAP YÜKSELTME sayfasından SADECE 15-TL'ye 1 yıl boyunca ÜCRETLİ ÜYELİK almanız yeterli olacaktır.
    Detaylı bilgilendirme için lütfen buraya tıklayınız!

    REKLAMSIZ FORUM KULLANMAYI TERCİH EDECEK ÜYELERİMİZE, https://www.exceldosyalari.com İSİMLİ SİTEMİZDEN 3 AYLIK ÜYELİK PAKETİ HEDİYE EDİLECEKTİR.

Genel f(×)  ehata fx' i eğer(ehatalıysa olarak değiştirmek

Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...

KMLZDMR

Yeni Üye
Kullanıcı
Katılım
25 Nis 2019
Mesajlar
158
Excel Versiyonu, Dili
excel 2003

Reputation:

Merhaba,
Forumda @teyadih tarafından
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
belgenin;
a) 4. penceredeki Teyadih'in ekli dosyasının 'Staj Belgesi (Uzatma)' sayfasının
E5 hücresindeki EHATA fonksiyonlu formül Excel 2003 de =_xlfn.IFERROR(DÜŞEYARA (H1;'Giriş Sayfası'!A:L;6;0);0) olarak görünmektedir.
E5 hücresindeki bu formülü =EĞER(EHATALIYSA(DÜŞEYARA (H1;'Giriş Sayfası'!A:L;6;0));0;DÜŞEYARA (H1;'Giriş Sayfası'!A:L;6;0)) şeklinde yazmama rağmen hiçbir işlem yapmıyor. Bu formülü nasıl EĞER(HATALIYSA formülüne dönüştürmek gerekli.
Buna rağmen aynı sayfadaki E2 hücresindeki =EHATA(DÜŞEYARA (H1;'Giriş Sayfası'!A:L;2;0);0) formülünü =EĞER(EHATALIYSA(DÜŞEYARA (H1;'Giriş Sayfası'!A:L;2;0));0;DÜŞEYARA (H1;'Giriş Sayfası'!A:L;2;0)) şeklinde düzenlediğimde formül değeri getiriyor. bu alandaki diğer hücrelerdeki de geliyor. Sadece E5 hücresi çalışmadı...

b) Sayın Ömer Baran' nın "5. penceresindeki formül olan ve eğerhata içeren aşağıdaki formülü de Eğer(Ehatalıysa formülünde nasıl düzenleyebiliriz.;
=EĞER(SATIR($A1)>MAK($Q$4:$Q$150);"";EĞERHATA(--KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0););KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0);)))
 
Moderatörün son düzenlenenleri:

PriveT

İlyas
Yönetici
Site Yöneticisi
SMS Onaylı
Katılım
26 Nis 2019
Mesajlar
416
Yaş
42
Web Sitesi
www.candiyet.net
Excel Versiyonu, Dili
Excel 2019 TR

Reputation:

Merhaba,
Forumda @teyadih tarafından
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
belgenin;
a) 4. penceredeki Teyadih'in ekli dosyasının 'Staj Belgesi (Uzatma)' sayfasının
E5 hücresindeki EHATA fonksiyonlu formül Excel 2003 de =_xlfn.IFERROR(DÜŞEYARA (H1;'Giriş Sayfası'!A:L;6;0);0) olarak görünmektedir.
E5 hücresindeki bu formülü =EĞER(EHATALIYSA(DÜŞEYARA (H1;'Giriş Sayfası'!A:L;6;0));0;DÜŞEYARA (H1;'Giriş Sayfası'!A:L;6;0)) şeklinde yazmama rağmen hiçbir işlem yapmıyor. Bu formülü nasıl EĞER(HATALIYSA formülüne dönüştürmek gerekli.
Buna rağmen aynı sayfadaki E2 hücresindeki =EHATA(DÜŞEYARA (H1;'Giriş Sayfası'!A:L;2;0);0) formülünü =EĞER(EHATALIYSA(DÜŞEYARA (H1;'Giriş Sayfası'!A:L;2;0));0;DÜŞEYARA (H1;'Giriş Sayfası'!A:L;2;0)) şeklinde düzenlediğimde formül değeri getiriyor. bu alandaki diğer hücrelerdeki de geliyor. Sadece E5 hücresi çalışmadı...

b) Sayın Ömer Baran' nın "5. penceresindeki formül olan ve eğerhata içeren aşağıdaki formülü de Eğer(Ehatalıysa formülünde nasıl düzenleyebiliriz.;
=EĞER(SATIR($A1)>MAK($Q$4:$Q$150);"";EĞERHATA(--KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0););KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0);)))
Uyarlamak istediğiniz fonksiyon EĞERHATA fonksiyonu.
Ben yazdığınız şekilde (boşlukları kaldırarak) denedim, formülünüz çalıştı.
Kod:
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
 
Son düzenleme:

KMLZDMR

Yeni Üye
Kullanıcı
Katılım
25 Nis 2019
Mesajlar
158
Excel Versiyonu, Dili
excel 2003

Reputation:

Merhaba,
Sayın PriveT a şıkkının ilgili dosyada hücre biçimlendirmeden kaynaklandığı anlaşıldı...
Ancak sorumun ikinci bölümü olan b) sorusuna sizden de Sayın Ömer Barandan da cevap gelmedi...
umarım gelir...

Forumda @teyadih tarafından
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
belgenin;
b) Sayın Ömer Baran' nın "5. penceresindeki formül olan ve eğerhata içeren aşağıdaki formülü de Eğer(Ehatalıysa formülünde nasıl düzenleyebiliriz.;
=
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
(
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($A1)>
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($Q$4:$Q$150);"";EĞERHATA(--
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($O$3;
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
(
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($A1);$Q$4:$Q$149;0););
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($O$3;
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
(
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($A1);$Q$4:$Q$149;0);)))

Teşekkür ederim.
 

Ömer BARAN

Kurucu
Yönetici
Kurucu
SMS Onaylı
Katılım
11 Nis 2019
Mesajlar
1,242
Web Sitesi
www.ExcelDestek.Com
Excel Versiyonu, Dili
2013 (32) TR

Reputation:

Merhaba Sayın @KMLZDMR .

Formülü aslında daha basit de kurgulayabilirmişim ama o kısmını geçeyim.
Önce şunu hatırlatayım formüldeki -- çift tire kısmını 1 x gibi düşünebilirsiniz.

Formül şöyle diyor;
KAYDIR(......) formülünün sonucununu 1 ile çarptığımızda sonuç hatalı mı değil mi?
-- sonuç bir sayı veya 1 ile çarptığımızda otomatik olarak SAYIya dönüşebilecek bir değer ise bu sonucu 1 ile ÇARP,
-- sonuç 1 ile çarpıldığında hata veriyorsa, yani METİN ise çarpma işlemi yapma KAYDIR(...) sonucunu yaz.

.
 

KMLZDMR

Yeni Üye
Kullanıcı
Katılım
25 Nis 2019
Mesajlar
158
Excel Versiyonu, Dili
excel 2003

Reputation:

Sayın Ömer Baran üstadım,
=
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
(
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($A1)>
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($Q$4:$Q$150);"";EĞERHATA(--
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($O$3;
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
(
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($A1);$Q$4:$Q$149;0););
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($O$3;
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
(
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($A1);$Q$4:$Q$149;0);)))
şeklinde yapmaya çalıştım. Ama "çok fazla bağımsız değişken girdiniz."uyarısı aldım.

=EĞER(SATIR($A1)>MAK($Q$4:$Q$150);"";EĞER(EHATALIYSA((--KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0););KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0);));(--KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0););KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0);))))

lütfen doğrusu nedir?
 

Ömer BARAN

Kurucu
Yönetici
Kurucu
SMS Onaylı
Katılım
11 Nis 2019
Mesajlar
1,242
Web Sitesi
www.ExcelDestek.Com
Excel Versiyonu, Dili
2013 (32) TR

Reputation:

Belgeyi çok hatırlamıyorum.

Aşağıdaki gibi sorun yaşamamanız lazım.
Rich (BB code):
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
 

KMLZDMR

Yeni Üye
Kullanıcı
Katılım
25 Nis 2019
Mesajlar
158
Excel Versiyonu, Dili
excel 2003

Reputation:

Sayın Ömer BARAN üstadım
Çok teşekkür ederim. Ancak şimdi fark edebildim hatalarımı.
 

Bilgi

Destek Takımı
Destek Ekibi
VIP
SMS Onaylı
Kullanıcı
Katılım
15 Eki 2019
Mesajlar
117
Web Sitesi
ExcelDestek.Com
Excel Versiyonu, Dili
Excel 2013 TR

Reputation:

Sayın @KMLZDMR
Sorunuz çözüme ulaşıldı ise konuyu çözüldü olarak işaretleyip, kilitleyelim.
 

KMLZDMR

Yeni Üye
Kullanıcı
Katılım
25 Nis 2019
Mesajlar
158
Excel Versiyonu, Dili
excel 2003

Reputation:

Çözüldü. İşaretleme nerede göremedim.
 

Bilgi

Destek Takımı
Destek Ekibi
VIP
SMS Onaylı
Kullanıcı
Katılım
15 Eki 2019
Mesajlar
117
Web Sitesi
ExcelDestek.Com
Excel Versiyonu, Dili
Excel 2013 TR

Reputation:

Mesaj içeriğine çözüldü kelimesi yazmanız yeterli olacaktır.
 
Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...
Üst