Soru ehata fx' i eğer(ehatalıysa olarak değiştirmek

Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...

KMLZDMR

VIP
VIP
Kullanıcı

Reputation:

Merhaba,
Forumda @teyadih tarafından
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
belgenin;
a) 4. penceredeki Teyadih'in ekli dosyasının 'Staj Belgesi (Uzatma)' sayfasının
E5 hücresindeki EHATA fonksiyonlu formül Excel 2003 de =_xlfn.IFERROR(DÜŞEYARA(H1;'Giriş Sayfası'!A:L;6;0);0) olarak görünmektedir.
E5 hücresindeki bu formülü =EĞER(EHATALIYSA(DÜŞEYARA(H1;'Giriş Sayfası'!A:L;6;0));0;DÜŞEYARA(H1;'Giriş Sayfası'!A:L;6;0)) şeklinde yazmama rağmen hiçbir işlem yapmıyor. Bu formülü nasıl EĞER(HATALIYSA formülüne dönüştürmek gerekli.
Buna rağmen aynı sayfadaki E2 hücresindeki =EHATA(DÜŞEYARA(H1;'Giriş Sayfası'!A:L;2;0);0) formülünü =EĞER(EHATALIYSA(DÜŞEYARA(H1;'Giriş Sayfası'!A:L;2;0));0;DÜŞEYARA(H1;'Giriş Sayfası'!A:L;2;0)) şeklinde düzenlediğimde formül değeri getiriyor. bu alandaki diğer hücrelerdeki de geliyor. Sadece E5 hücresi çalışmadı...

b) Sayın Ömer Baran' nın "5. penceresindeki formül olan ve eğerhata içeren aşağıdaki formülü de Eğer(Ehatalıysa formülünde nasıl düzenleyebiliriz.;
=EĞER(SATIR($A1)>MAK($Q$4:$Q$150);"";EĞERHATA(--KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0););KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0);)))
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Moderatörün son düzenlenenleri:

PriveT

İlyas
Yönetici
Site Yöneticisi

Reputation:

Merhaba,
Forumda @teyadih tarafından
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
belgenin;
a) 4. penceredeki Teyadih'in ekli dosyasının 'Staj Belgesi (Uzatma)' sayfasının
E5 hücresindeki EHATA fonksiyonlu formül Excel 2003 de =_xlfn.IFERROR(DÜŞEYARA(H1;'Giriş Sayfası'!A:L;6;0);0) olarak görünmektedir.
E5 hücresindeki bu formülü =EĞER(EHATALIYSA(DÜŞEYARA(H1;'Giriş Sayfası'!A:L;6;0));0;DÜŞEYARA(H1;'Giriş Sayfası'!A:L;6;0)) şeklinde yazmama rağmen hiçbir işlem yapmıyor. Bu formülü nasıl EĞER(HATALIYSA formülüne dönüştürmek gerekli.
Buna rağmen aynı sayfadaki E2 hücresindeki =EHATA(DÜŞEYARA(H1;'Giriş Sayfası'!A:L;2;0);0) formülünü =EĞER(EHATALIYSA(DÜŞEYARA(H1;'Giriş Sayfası'!A:L;2;0));0;DÜŞEYARA(H1;'Giriş Sayfası'!A:L;2;0)) şeklinde düzenlediğimde formül değeri getiriyor. bu alandaki diğer hücrelerdeki de geliyor. Sadece E5 hücresi çalışmadı...

b) Sayın Ömer Baran' nın "5. penceresindeki formül olan ve eğerhata içeren aşağıdaki formülü de Eğer(Ehatalıysa formülünde nasıl düzenleyebiliriz.;
=EĞER(SATIR($A1)>MAK($Q$4:$Q$150);"";EĞERHATA(--KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0););KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0);)))
Uyarlamak istediğiniz fonksiyon EĞERHATA fonksiyonu.
Ben yazdığınız şekilde (boşlukları kaldırarak) denedim, formülünüz çalıştı.
Kod:
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Son düzenleme:

KMLZDMR

VIP
VIP
Kullanıcı

Reputation:

Merhaba,
Sayın PriveT a şıkkının ilgili dosyada hücre biçimlendirmeden kaynaklandığı anlaşıldı...
Ancak sorumun ikinci bölümü olan b) sorusuna sizden de Sayın Ömer Barandan da cevap gelmedi...
umarım gelir...

Forumda @teyadih tarafından
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
belgenin;
b) Sayın Ömer Baran' nın "5. penceresindeki formül olan ve eğerhata içeren aşağıdaki formülü de Eğer(Ehatalıysa formülünde nasıl düzenleyebiliriz.;
=
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
(
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($A1)>
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($Q$4:$Q$150);"";EĞERHATA(--
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($O$3;
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
(
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($A1);$Q$4:$Q$149;0););
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($O$3;
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
(
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($A1);$Q$4:$Q$149;0);)))

Teşekkür ederim.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Ömer BARAN

Kurucu
Yönetici
Kurucu

Reputation:

Merhaba Sayın @KMLZDMR .

Formülü aslında daha basit de kurgulayabilirmişim ama o kısmını geçeyim.
Önce şunu hatırlatayım formüldeki -- çift tire kısmını 1 x gibi düşünebilirsiniz.

Formül şöyle diyor;
KAYDIR(......) formülünün sonucununu 1 ile çarptığımızda sonuç hatalı mı değil mi?
-- sonuç bir sayı veya 1 ile çarptığımızda otomatik olarak SAYIya dönüşebilecek bir değer ise bu sonucu 1 ile ÇARP,
-- sonuç 1 ile çarpıldığında hata veriyorsa, yani METİN ise çarpma işlemi yapma KAYDIR(...) sonucunu yaz.

.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

KMLZDMR

VIP
VIP
Kullanıcı

Reputation:

Sayın Ömer Baran üstadım,
=
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
(
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($A1)>
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($Q$4:$Q$150);"";EĞERHATA(--
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($O$3;
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
(
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($A1);$Q$4:$Q$149;0););
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($O$3;
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
(
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
($A1);$Q$4:$Q$149;0);)))
şeklinde yapmaya çalıştım. Ama "çok fazla bağımsız değişken girdiniz."uyarısı aldım.

=EĞER(SATIR($A1)>MAK($Q$4:$Q$150);"";EĞER(EHATALIYSA((--KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0););KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0);));(--KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0););KAYDIR($O$3;KAÇINCI(SATIR($A1);$Q$4:$Q$149;0);))))

lütfen doğrusu nedir?
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Ömer BARAN

Kurucu
Yönetici
Kurucu

Reputation:

Belgeyi çok hatırlamıyorum.

Aşağıdaki gibi sorun yaşamamanız lazım.
Rich (BB code):
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

KMLZDMR

VIP
VIP
Kullanıcı

Reputation:

Sayın Ömer BARAN üstadım
Çok teşekkür ederim. Ancak şimdi fark edebildim hatalarımı.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Bilgi

Forum Yönetimi
Yönetici
Site Yöneticisi

Reputation:

Sayın @KMLZDMR
Sorunuz çözüme ulaşıldı ise konuyu çözüldü olarak işaretleyip, kilitleyelim.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

KMLZDMR

VIP
VIP
Kullanıcı

Reputation:

Çözüldü. İşaretleme nerede göremedim.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Bilgi

Forum Yönetimi
Yönetici
Site Yöneticisi

Reputation:

Mesaj içeriğine çözüldü kelimesi yazmanız yeterli olacaktır.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...

Benzer Konular

Üst