• Web sitemizin SORU-CEVAP bölümünde dosya yüklemek ve dosya indirmek günlük limitlere bağlı olarak ÜCRETSİZ'dir.
    Gizlilik kapsamında, sadece site yöneticilerimizin ve üyenin kendisinin görebileceği ÜCRETLİ ÖZEL DESTEK alanımız mevcuttur.

Çözüldü Farklı guruplardaki aynı isimleri toplama

REKLAM

Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...

xapex

Yeni Üye
Kullanıcı
Yaş
41
Versiyon
  1. Excel 2016
Sürüm
  1. 64 bit
Dil
  1. Türkçe

Reputation:

Merhabalar Arkadaşlar;
Resimde anlatmaya çalıştım aslında ama kısaca şöyle özetlemek istiyorum.
soldaki (1 nolu alan) isimleri formülle sağdaki (2 nolu alan) şekilde kısaltmak istiyorum.
her guruptaki aynı isimleri yine grup grup olarak isimleri sağdaki gibi adetlerini toplamamız mümkün müdür acaba?

umarım anlatabilmişimdir. Şimdiden teşekkür ederim.
ek.JPG
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Çözüm
Selamlar,
@Ömer BARAN 'ın müsaadeleriyle,
Çeşitlilik olması açısından
alternatif bir çözüm eklemek istedim...

1613686612603.png

Resimden de görüleceği üzere, hem listedeki sırasına göre ve hem de alfabetik sıralı olarak listeleme yapılmakta...
** Sayfa1 de kullanılan formüllerdeki hücre referans aralıkları listenizdeki referans aralığıdır. (Örneğin A2:A19 gibi)... Listenizdeki Satır adedi değişkenlik seyrettikçe formüllerdeki referansları da değiştirmek gerekecektir.
** Sayfa2 de ise listedeki satır adedi değişkenlik seyretse de etkilenmeyecek şekilde Ad Tanımlamaları kullanılarak Dinamik alanlar oluşturuldu ve formüllerde kullanıldı...

Sayfa 1 de
E3 hücresinde DİZİ...

Ömer BARAN

Kurucu
Yönetici
Kurucu
Versiyon
  1. Excel 2013
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

Merhaba, foruma hoşgeldiniz Sayın @xapex .

Sorularınızı, ekran görüntüsü yerine
cevabımın altındaki İMZA bölümünde yer alan açıklamalar doğrultusunda hazırlayacağınız
örnek belge üzerinden sorarasanız, daha hızlı sonuca ulaşmanız, alternatif çözüm önerileri almanız kolaylaşır.

Forumumuzun SORU-CEVAP bölümünde örnek belge eklemek/indirmek için özel bir üyelik türü yoktur.

.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

xapex

Yeni Üye
Kullanıcı
Yaş
41
Versiyon
  1. Excel 2016
Sürüm
  1. 64 bit
Dil
  1. Türkçe

Reputation:

Teşekkür ederim bilgilendirmeniz için
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Ekli dosyalar

  • örnek_dosya.xlsx
    10.9 KB · Görüntüleme: 4

Ömer BARAN

Kurucu
Yönetici
Kurucu
Versiyon
  1. Excel 2013
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

Çözümünüz ekte.
İlk 2 grup için formülleri uyguladım.
Üçüncü grubun formüllerini, 2'nci grup formülüne bakarak kendiniz oluşturursunuz (eğitim-öğrenme).

İsim listeleme formülleri dizi formülüdür (CTRL+SHIFT+ENTER ile formül uygulaması).
Bu uygulama yönteminin sonucu, formül kendiliğinden {....} gibi köşeli parantez arasına alınmış olur.
Bu işaretler, klavyeden yazarak eklenmemelidir.

.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Ekli dosyalar

  • örnek_dosya.xlsx
    11.8 KB · Görüntüleme: 5

xapex

Yeni Üye
Kullanıcı
Yaş
41
Versiyon
  1. Excel 2016
Sürüm
  1. 64 bit
Dil
  1. Türkçe

Reputation:

Ayrıntılı bilgilendirme için çok teşekkür ederim. Üçüncü grubun formülleri de dahil tüm formülleri okuldaki tüm öğrencilerim için uygulayabilirim artık. Elleriniz dert görmesin.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

xapex

Yeni Üye
Kullanıcı
Yaş
41
Versiyon
  1. Excel 2016
Sürüm
  1. 64 bit
Dil
  1. Türkçe

Reputation:

Çözümünüz ekte.
İlk 2 grup için formülleri uyguladım.
Üçüncü grubun formüllerini, 2'nci grup formülüne bakarak kendiniz oluşturursunuz (eğitim-öğrenme).

İsim listeleme formülleri dizi formülüdür (CTRL+SHIFT+ENTER ile formül uygulaması).
Bu uygulama yönteminin sonucu, formül kendiliğinden {....} gibi köşeli parantez arasına alınmış olur.
Bu işaretler, klavyeden yazarak eklenmemelidir.

.

Şöyle bir durum farkettim:

Soldaki herhangi bir gruba yeni bir isim eklediğimde yada ortak olan bir ismi yeni (olmayan) bir isimle değiştirdiğimde sağdaki isimlerin olduğu sütunda isimler otomatik olarak eklenmiyor. isimleri de otomatik güncelleyemezmiyiz?

( Örneğin; Soldaki İlk sütundaki 1. gurubun ilk sırasındaki ALİ'yi MEHMET yaptığımda 2.alandaki Ahmet siliniyor)
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Ömer BARAN

Kurucu
Yönetici
Kurucu
Versiyon
  1. Excel 2013
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

Örnek belgenin, gerçek belgenizle aynı yapıda olduğundan emin misiniz?
Gerçek belgenizdeki yapı farklı ise oluşturulan formül, yazılan cevaplar malesef ÇÖP haline geliyor.

Öncelikle Ms. Excel'deki genel veri tutma, formüllerle/makrolarla bu veriler üzerinden özet bilgiler oluşturma işlemlerinde
veri tabanı mantığıyla hareket etmenin, bir sütunda TEK TİP veri/formül tutmanın önemini hatırlatacağım.

Dosya üzrinden söylersem; diyelim 1 numaralı gruptan söz ediyoruz.
bu alandaki benzersiz isim adeti için ayırrdığınız satır sayısı 4 ve formülü de bu 4 satıra uyguladınız.
Aynı grupta ya 5 farklı isim varsa ne olacak? E sütununda 1'inci gruba ait formüllerin 1 satır aşağı daha kopyalanması gerekecek.

Özetle şöyle söyleyeyim;
-- Herbir gruba yönelik formülleri ayrı sütunlara uygulayın.
Örneğin 1'inci grup için E-F sütununu, 2'nci grup için G-H sütununu, 3'üncü grup için I-J sütunlarını kullanın.
-- Verdiğim formülleri de =EĞERHATA( ...verdiğim formül... ; "" ) şeklinde değiştirin ki hata oluşmasın.

A-C sütunlarındaki grupların bulunduğu alanlar (satır adetleri, farklı isim adetleri vs) değişkense
kullanılacak formüller biraz uzayacak ve karmaşıklaşacaktır yani formüllerin değiştirilmesi gerekecektir.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

xapex

Yeni Üye
Kullanıcı
Yaş
41
Versiyon
  1. Excel 2016
Sürüm
  1. 64 bit
Dil
  1. Türkçe

Reputation:

Ne demek istediğinizi çok iyi anladım, ayrıntılı bilgi verdiğiniz ve hızlı geri dönüşünüz için çok teşekkür ederim.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Ömer BARAN

Kurucu
Yönetici
Kurucu
Versiyon
  1. Excel 2013
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

En iyisi çözümü de vereyim.

Aşağıdaki;
-- birinci formülü E2 hücresine dizi formülü (CTRL+SHIFT+ENTER) olarak uygulayın ve
BOŞ sonuç alıncaya kadar aşağı doğru kopyalayın,
-- ikinci formülü de (normal formül) F2 hücresine uygulayıp aşağı doğru kopyalayın.

Artık E1 hücresindeki grup no bilgisini değiştirdiğinizde o gruba ait sonuçları alırsınız.
Formül, grup no bilgisine göre sıralanmış veri yığınının kaç satırlık bir alanda olduğundan,
aranan grup no bilgisinin kaç kez tekrarlandığından vs etkilenmez, her türlü sonuç alırsınız.

C#:
=EĞERHATA(KAYDIR($A$1;KÜÇÜK(EĞER(KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);)=E$1;EĞER(EĞERSAY(E$1:E1;KAYDIR($B$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))=0;SATIR(KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))));1)-1;1);"")

=EĞER(E2="";"";TOPLA.ÇARPIM((KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);)=E$1)*(KAYDIR($B$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);)=E2)*(KAYDIR($C$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))))

.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

xapex

Yeni Üye
Kullanıcı
Yaş
41
Versiyon
  1. Excel 2016
Sürüm
  1. 64 bit
Dil
  1. Türkçe

Reputation:

bu çok çok daha güzel oldu. çok Teşekkür ediyorum, emeklerinize sağlık
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

52779

Forum Yönetimi
Yönetici
Site Yöneticisi
Versiyon
  1. Ofis 365
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

Selamlar,
@Ömer BARAN 'ın müsaadeleriyle,
Çeşitlilik olması açısından
alternatif bir çözüm eklemek istedim...

1613686612603.png

Resimden de görüleceği üzere, hem listedeki sırasına göre ve hem de alfabetik sıralı olarak listeleme yapılmakta...
** Sayfa1 de kullanılan formüllerdeki hücre referans aralıkları listenizdeki referans aralığıdır. (Örneğin A2:A19 gibi)... Listenizdeki Satır adedi değişkenlik seyrettikçe formüllerdeki referansları da değiştirmek gerekecektir.
** Sayfa2 de ise listedeki satır adedi değişkenlik seyretse de etkilenmeyecek şekilde Ad Tanımlamaları kullanılarak Dinamik alanlar oluşturuldu ve formüllerde kullanıldı...

Sayfa 1 de
E3 hücresinde DİZİ formül olarak
Kod:
=EĞERHATA(İNDİS($B$2:$B$19;KAÇINCI(0;EĞER(F$1=$A$2:$A$19;EĞERSAY(E$2:E2;$B$2:$B$19);"");0));"")
F3 hücresinde Standart formül olarak
Kod:
=EĞER(E3="";"";TOPLA.ÇARPIM(($A$2:$A$19=F$1)*($B$2:$B$19=E3)*($C$2:$C$19)))
N3 hücresinde DİZİ Formül olarak
Kod:
=EĞERHATA(İNDİS($B$2:$B$19;KAÇINCI(KÜÇÜK(EĞER((EĞERSAY(N$2:N2;$B$2:$B$19)=0)*($A$2:$A$19=O$1);EĞERSAY($B$2:$B$19;"<"&$B$2:$B$19);"");1);EĞERSAY($B$2:$B$19;"<"&$B$2:$B$19);0));"")

Sayfa2 de ise Dinamik alanlar için ad tanımlamaları
k
= KAÇINCI(9^99;Sayfa2!$A$2:$A$5001) (Listedeki A kolonunda son dolu satır için Liste Satır Adedinin bulunması)
Ad = KAYDIR(Sayfa2!$B$2;;;k;1)
Adet = KAYDIR(Sayfa2!$C$2;;;k;1)
Gurup = KAYDIR(Sayfa2!$A$2;;;k;1)

şeklindedir. Bu dinamik alanlar formüllerde kullanılmıştır.
Yani
E3 hücresinde DİZİ formül olarak
Kod:
=EĞERHATA(İNDİS(Ad;KAÇINCI(0;EĞER(F$1=Gurup;EĞERSAY(E$2:E2;Ad);"");0));"")
F3 hücresinde Standart formül olarak
Kod:
=EĞER(E3="";"";TOPLA.ÇARPIM((Gurup=F$1)*(Ad=E3)*(Adet)))
N3 hücresinde DİZİ Formül olarak
Kod:
=EĞERHATA(İNDİS(Ad;KAÇINCI(KÜÇÜK(EĞER((EĞERSAY(N$2:N2;Ad)=0)*(Gurup=O$1);EĞERSAY(Ad;"<"&Ad);"");1);EĞERSAY(Ad;"<"&Ad);0));"")

Dosyanız ektedir...

Not : Sayfa3 e de hem liste sırasına göre ve hem de alfabetik sıralı benzersizlerin sıralanması olarak, Açılır Listeden Gurup No seçilerek listeleme yapılması eklendi... Düzenleme yapılarak yeni dosya eklendi...(19.02.2021 02:28)
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Ekli dosyalar

  • örnek_dosya.xlsx
    45.1 KB · Görüntüleme: 5
Son düzenleme:
Çözüm

xapex

Yeni Üye
Kullanıcı
Yaş
41
Versiyon
  1. Excel 2016
Sürüm
  1. 64 bit
Dil
  1. Türkçe

Reputation:

Hocam harika bir çalışma olmuş, elinize kolunuza emeklerinize sağlık. Benim için müthiş bir kaynak oldu bunların tamamı.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

52779

Forum Yönetimi
Yönetici
Site Yöneticisi
Versiyon
  1. Ofis 365
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

Ben teşekkür ediyorum...
Kolaylar gelsin sizlere...
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

KMLZDMR

VIP
VIP
Kullanıcı
Versiyon
  1. Excel 2003
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

En iyisi çözümü de vereyim.

Aşağıdaki;
-- birinci formülü E2 hücresine dizi formülü (CTRL+SHIFT+ENTER) olarak uygulayın ve
BOŞ sonuç alıncaya kadar aşağı doğru kopyalayın,
-- ikinci formülü de (normal formül) F2 hücresine uygulayıp aşağı doğru kopyalayın.

Artık E1 hücresindeki grup no bilgisini değiştirdiğinizde o gruba ait sonuçları alırsınız.
Formül, grup no bilgisine göre sıralanmış veri yığınının kaç satırlık bir alanda olduğundan,
aranan grup no bilgisinin kaç kez tekrarlandığından vs etkilenmez, her türlü sonuç alırsınız.

C#:
=EĞERHATA(KAYDIR($A$1;KÜÇÜK(EĞER(KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);)=E$1;EĞER(EĞERSAY(E$1:E1;KAYDIR($B$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))=0;SATIR(KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))));1)-1;1);"")

=EĞER(E2="";"";TOPLA.ÇARPIM((KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);)=E$1)*(KAYDIR($B$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);)=E2)*(KAYDIR($C$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))))

.
Sayın Ömer Baran üstadım,
E2 hücresi formülünü Eğer(Ehatalıysa(... parantezine aşağıdaki gibi aldım ama çalıştıramadım... Nasıl yapılması gerekli?
Lütfen, yapabilir misiniz.
Not: Dizi formülü (CTRL+SHIFT+ENTER) olarak uyguladığımda fare koddaki kırmızı renkli "kaçıncı" ya geldi...
Kod:
=EĞER(EHATALIYSA(KAYDIR($A$1;KÜÇÜK(EĞER(KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);)=E$1;EĞER(EĞERSAY(E$1:E1;KAYDIR($B$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))=0;SATIR(KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))));1)-1;1));"";KAYDIR($A$1;KÜÇÜK(EĞER(KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);)=E$1;EĞER(EĞERSAY(E$1:E1;KAYDIR($B$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))=0;SATIR(KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))));1)-1;1)))
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Ömer BARAN

Kurucu
Yönetici
Kurucu
Versiyon
  1. Excel 2013
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

Formülü oluşturmuşsunuz zaten.
Formül hücrede yazılıyken formül çubuğunun solundaki f(x) tuşuna basıp,
İMLEÇin aralıklarla EĞER'den sonraki açılan parantezin sağına-soluna gelmesini sağlarsanız;
formülün en sonundaki 1 adet parantez işaretinin fazla olduğunu fark edersiniz.

Formülde sorun yok, sondaki 1 parantez fazla o kadar.

.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

KMLZDMR

VIP
VIP
Kullanıcı
Versiyon
  1. Excel 2003
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

Formülü oluşturmuşsunuz zaten.
Formül hücrede yazılıyken formül çubuğunun solundaki f(x) tuşuna basıp,
İMLEÇin aralıklarla EĞER'den sonraki açılan parantezin sağına-soluna gelmesini sağlarsanız;
formülün en sonundaki 1 adet parantez işaretinin fazla olduğunu fark edersiniz.

Formülde sorun yok, sondaki 1 parantez fazla o kadar.

.
Üstadım Sondaki parantezin fazlalığını gördüm. Sildim. Fare yine aynı yerde kaldı. "Yazdığınız formülde hata var..." uyarısı aldım.
imleçleri takip ettim.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Ömer BARAN

Kurucu
Yönetici
Kurucu
Versiyon
  1. Excel 2013
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

Ben de sizin cevabınızdaki formülü kopyalayıp, sondaki parantezi sildim ve boş bir belgede herhangi bir hücreye
DİZİ FORMÜLÜ olarak uyguladım. Bir hata/uyarı almadım.

Formülün uygulandığı belgeyi açmış dahi değilim.
Yanılmıyorsam, formülde beklenen HATA (başka hata verecek bir şey olmamalı), KAÇINCI işlevinin olduğu kısım.
O halde EHATALIYSA parantezinin içine sadece KAÇINCI(.....) kısmını alsanız da olur. Hem böylece formül de kısalır.

.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

KMLZDMR

VIP
VIP
Kullanıcı
Versiyon
  1. Excel 2003
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

Malesef yapamadım...
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Ömer BARAN

Kurucu
Yönetici
Kurucu
Versiyon
  1. Excel 2013
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

Şöyle deneyin.
(hata kaynağının sadece KAÇINCI(E$1;$A:$A;0) kısmı olacağı varsayımıyla)

C#:
=EĞER(EHATALIYSA(KAÇINCI(E$1;$A:$A;0));"";KAYDIR($A$1;KÜÇÜK(EĞER(KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);)=E$1;EĞER(EĞERSAY(E$1:E1;KAYDIR($B$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))=0;SATIR(KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))));1)-1;1))
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

KMLZDMR

VIP
VIP
Kullanıcı
Versiyon
  1. Excel 2003
Sürüm
  1. 32 bit
Dil
  1. Türkçe

Reputation:

Şöyle deneyin.
(hata kaynağının sadece KAÇINCI(E$1;$A:$A;0) kısmı olacağı varsayımıyla)

C#:
=EĞER(EHATALIYSA(KAÇINCI(E$1;$A:$A;0));"";KAYDIR($A$1;KÜÇÜK(EĞER(KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);)=E$1;EĞER(EĞERSAY(E$1:E1;KAYDIR($B$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))=0;SATIR(KAYDIR($A$1;KAÇINCI(E$1;$A:$A;0)-1;;EĞERSAY($A:$A;E$1);))));1)-1;1))
Üstad formül çalıştı. Ancak E1 hücresi 2 seçili iken E5 hücresinde #SAYI! hatası aldı. Çünkü B sütununda Ahmet yok.
Bu durumda formül nasıl revize edilmeli.
 



Forumumuzu reklamsız kullanmak, Hazır Excel Dosyaları indirmek ve web sitemize destek olmak için Hesap Yükseltme yapabilirsiniz. Detayları buradan inceleyebilir, hemen hesabınızı yükseltebilirsiniz.

Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...
Üst