Sitemize Hoşgeldiniz

Türkiye'nin en geniş özeliklere sahip forumu olan ExcelDestek.Com üzerinde soru sorabilmek, daha önceki sorulan sorulara, açılan konulara cevap yazabilmek, puan kazanabilmek, kazandığınız puanlar ile dosya indirebilmek ve çok daha fazla özellikten yararlanabilmek için sitemize üye olunuz.
Hemen Üye Ol ya da Giriş Yap

Sorun Cevaplayalım

Excel'e dair sorularınızı sorun, cevaplayalım.

Çözümlenmiş Sorular

Kullanıcılarımızın sorularını ve sunduğumuz çözümleri inceleyin.

Destek Ekibimiz Sizlerle

Ücretli destek ve özel hizmet talep edebilirsiniz.

  • Web sitemizi "REKLAMSIZ" olarak ziyaret etmek ister misiniz?
    Gerek sitemize destek, gerekse de reklam görmeden sitemizde gezinmek isterseniz, HESAP YÜKSELTME sayfasından SADECE 15-TL'ye 1 yıl boyunca ÜCRETLİ ÜYELİK almanız yeterli olacaktır.
    Detaylı bilgilendirme için lütfen buraya tıklayınız!

    REKLAMSIZ FORUM KULLANMAYI TERCİH EDECEK ÜYELERİMİZE, https://www.exceldosyalari.com İSİMLİ SİTEMİZDEN 1 AYLIK ÜYELİK PAKETİ HEDİYE EDİLECEKTİR.

Genel f(×)  kritere göre oransal dağılım

KMLZDMR

Yeni Üye
Kullanıcı
Katılım
25 Nis 2019
Mesajlar
196
Excel Versiyonu, Dili
excel 2003

Reputation:

Merhaba,
Ekli dosyada B sütununda orantısal dağılımı yapılmış ve toplamı 1 olan oranlar var.
C Sütununda da Evet/Hayır olarak işaretlenmiş kriterler
D sütunu yapılacak yeni dağılımda sadece C sütununda 1 değeri dağıtılacak.
Klit nokta C sütunda Hayır işaretli olanların toplamı olan B sütunundaki değerler diğer evetlerin oranında olamak üzere D sütununa nasıl dağıtalım ki
Evet lan B sütunundaki kendi değeri ile topladığımız zaman satırların toplamı (D sütunu değerler toplamı) 1 sonucu versin.
 

Ekli dosyalar

PriveT

İlyas
Yönetici
Site Yöneticisi
SMS Onaylı
Katılım
26 Nis 2019
Mesajlar
592
Yaş
42
Web Sitesi
www.candiyet.net
Excel Versiyonu, Dili
Excel 2019 TR

Reputation:

Merhaba,
Doğru anladıysam D3 hücresine aşağıdaki formülü yapıştırıp aşağı kadar sürükleyerek çoğaltınız.

Kod:
Değerli ziyaretçimiz lütfen, içeriği görüntüleyebilmek için Giriş Yap veya Kayıt Ol anlayışınız için teşekkürler.
Not: Formül örnek dosyanızdaki satır ve sütunların yer ve sayısına göre düzenlenmiştir. İhtiyacınız doğrultusunda düzenleyiniz.
 

Ekli dosyalar

KMLZDMR

Yeni Üye
Kullanıcı
Katılım
25 Nis 2019
Mesajlar
196
Excel Versiyonu, Dili
excel 2003

Reputation:

Sayın #PriveT Çalıştı. Teşekkür ederim. Ancak
formülde Hatır olan değerler satır sayısına bölününce eşit oranda artı işlemi olmuş.
hayırların değerinin yine B sütunundaki oranlarda dağılması gerekli...
 

KMLZDMR

Yeni Üye
Kullanıcı
Katılım
25 Nis 2019
Mesajlar
196
Excel Versiyonu, Dili
excel 2003

Reputation:

Sayın #PriveT formül çalıştı.
Ancak, formülde Hayır olan değerler satır sayısına bölününce eşit oranda eklenmiş oluyor.
Hayırların değerinin yine B sütunundaki oranlarda dağılması gerekli... formülü buna göre revize edilmesi mümkün mü?
Sizin formüldeki yöntemle Örnekteki Evet lerin B sütunundaki dağılım oranlarındaki gibi eşit olmayan oranlarda dağılması uygun olacaktır.
%38 oran evet lerin satır sayısı olan 9 rakamına bölünmüş durumda...
 

PriveT

İlyas
Yönetici
Site Yöneticisi
SMS Onaylı
Katılım
26 Nis 2019
Mesajlar
592
Yaş
42
Web Sitesi
www.candiyet.net
Excel Versiyonu, Dili
Excel 2019 TR

Reputation:

Sayın @KMLZDMR
B sütunundaki değerlerin arasındaki oranı anlayamadım. Neye göre orantıladınız açıklayabilir misiniz?
 

KMLZDMR

Yeni Üye
Kullanıcı
Katılım
25 Nis 2019
Mesajlar
196
Excel Versiyonu, Dili
excel 2003

Reputation:

B Sütunu değerleri başka bağlantı ile orantısı bulunmuş değer olup ikinci orantı bulunacak D sütunu değeri B sütunundaki Evet olanlara rakamsal dağılım yapılacak...
 

PriveT

İlyas
Yönetici
Site Yöneticisi
SMS Onaylı
Katılım
26 Nis 2019
Mesajlar
592
Yaş
42
Web Sitesi
www.candiyet.net
Excel Versiyonu, Dili
Excel 2019 TR

Reputation:

İşte ben de o orantıyı neye göre ayarlamam gerektiğini anlayamadım malesef.
Belki ben anlayamamışımdır bir anlayan çıkıp yanıtlar.
Veya Manuel olarak olması gerektiği şekilde D sütunundaki rakamları yazıp, neye göre o değerleri aldığını açıklarsanız ben de yardımcı olmaya çalışırım.
 

KMLZDMR

Yeni Üye
Kullanıcı
Katılım
25 Nis 2019
Mesajlar
196
Excel Versiyonu, Dili
excel 2003

Reputation:

Üstadım, yenilediğim belgede G sütununda değerlere göre B sütundaki oranları elde etmekteyim. G sütunundaki değerleri C deki evet/hayırla formüle edebilmekteyim. Ama aradığım oranlama G sütunu yokmuş gibi önceki pencerelerdeki izaha göre formül oluşturabilmek...
 

Ekli dosyalar

PriveT

İlyas
Yönetici
Site Yöneticisi
SMS Onaylı
Katılım
26 Nis 2019
Mesajlar
592
Yaş
42
Web Sitesi
www.candiyet.net
Excel Versiyonu, Dili
Excel 2019 TR

Reputation:

Not: Dosyalarınızı (çok büyük olmadığı sürece) sıkıştırmadan yükleyebilirsiniz.
 

KMLZDMR

Yeni Üye
Kullanıcı
Katılım
25 Nis 2019
Mesajlar
196
Excel Versiyonu, Dili
excel 2003

Reputation:

Teşekkür ederim sayın #Privet
Basit olarak aşağıdaki formülleri yapmıştım. Ancak aradığım benim yaptığım değildi.
Sizinki gibiydi. Sağolun bu çok güzel. Ancak G sütunundaki değerler olmadan başkaca yöntem bulmak mümkün olursa onu da siz ve diğer forumdaşlardan beklerim.
Acil değil.

d15 hücresi formülü> =ETOPLA($C$3:$C$12;"evet";$G$3:$G$12)
d3 hücresinden aşağı doğru sürklenecek formül> =EĞER(C3="evet";G3/$D$15;0)
şeklinde yapmıştım.
 

KMLZDMR

Yeni Üye
Kullanıcı
Katılım
25 Nis 2019
Mesajlar
196
Excel Versiyonu, Dili
excel 2003

Reputation:

Çok teşekkür ederim. Harika olmuş. (Çözüldü)
 
Üst