Excel'deki arama işlemlerinin kafa karıştırıcı yönlerinden biri, bir veri aralığında yer alan birden fazla eşleşmede ilk veya son eşleşmenin nasıl bulunacağını anlamaktır.

Örneğin, aşağıdaki verilerde "Yeşil" fiyatını bulmak için DÜŞEYARA'yı kullandığımızı varsayalım. Hangi fiyatı alacağız?

Düşeyara


Tam Eşleşme - İlk Bulunan Değer

Tam eşleşme yaparken, her zaman ilk bulunan değer gelir. Verilerin sıralanıp sıralanmadığı önemli değildir. Aşağıdaki resimde, E3'teki arama değeri "Kırmızı" dır. DÜŞEYARA fonksiyonu, tam eşleşme modunda ilk bulduğu Kırmızı'nın fiyatını sonuç olarak verir.

=DÜŞEYARA(E3;B3:C9;2;0)

Düşeyara ilk eşleşen


Tam eşleşmeyi zorlamak için DÜŞEYARA'daki son argümanın 0 (YANLIŞ) olduğuna dikkat edin.

Yaklaşık Eşleşme = Son Bulunan Değer

Yaklaşık bir eşleşme yapıyorsanız ve veriler arama değerine göre sıralanırsa, son eşleşmeyi elde edersiniz. Peki neden?
Çünkü yaklaşık bir eşleşme sırasında Excel, arama değerinden daha büyük bir değer bulunana kadar diğer değerleri tarar ve önceki değere geri adım atar.

Aşağıdaki resimde, DÜŞEYARA yaklaşık eşleşme moduna ayarlanmış ve renkler sıralanmıştır. DÜŞEYARA, son "Yeşil" rengin fiyatının sonucunu verir.

=DÜŞEYARA(E3;B3:C9;2;1)

Düşeyara yaklaşık eşleşme


DÜŞEYARA'daki son argümanın yaklaşık eşleşme için 1 (DOĞRU) olduğuna dikkat edin.