Formüllerin elemanları üzerinde yapılmak istenilen hesaplama türüişleçler belirtir ve bu işleçler için varsayılan bir öncelik sıralaması vardır.

İşleçler
  1. Aritmetik işleçler

    SAYIsal sonuç elde etmek için kullanılan aritmetik işleçler;
    • toplama ( = 5 + 2 ® sonuç: 7 ),
    • çıkarma ( = 8 – 3 ® sonuç: 5 )
    • çarpma ( = 2 * 3 ® sonuç: 7 ),
    • bölme ( = 15 / 3 ® sonuç: 5 ),
    • olumsuzlama yani negatife döndürme ( –1 gibi ),
    • yüzde (= 20% * 90 ® sonuç: 18 ),
    • üssünü alma ( = 4 ^ 3 ® sonuç: 64 )
      şeklinde sıralanabilir.
  2. Karşılaştırma işleçleri

    Karşılaştırma işleçleri; adından da anlaşılacağı üzere sonucu DOĞRU veya YANLIŞ olan işleçlerdir ve
    • “=” (eşittir işareti) ,
    • “>” (büyüktür işareti),
    • “<” (küçüktür işareti),
    • “>=” (büyüktür veya eşittir işareti),
    • “<=” (küçüktür veya eşittir işareti),
    • “<>” (eşit değildir işareti)
      şeklinde sıralanabilir ve =A1=A2, = A1>=A2, =A1<>A2 gibi kullanılır.
  3. Metin birleştirme işleci

    Birleştirme işleci olan “ & “ simgesi esas olarak Türkçe’mizdeki İLE bağlacına karşılık gelir.Bu işleç ile iki ayrı METİN birleştirilebilir ve aşağıdaki gibi kullanılabilir.
    = “Milli Mücadele, Mustafa Kemal Atatürk’ün, “ & “19 Mayıs 1919 günü Samsun’a çıkışıyla başlar.”
    & simgesiyle birleştirilen METİN parçaları, = A1 & A2 gibi hücrelere atıf yapılarak ya da
    = “Bugün, saat “ & METNEÇEVİR(A1/24;“ss:dd”) & “ ‘de yola çıkacağım.”
    gibi başka hücredeki SAYIsal değerleri METİNe çevirerek de kullanılabilir.

  4. Başvuru işleçleri

    Başvuru işleçleri; formüllerle yapılacak hesaplamalarda, işleme tabi tutulacak ALANları (hücre aralıklarını) belirtmek üzere; iki nokta üst üste işleci, noktalı virgül işleci ve boşluk işleci olarak sıralanabilir.
    • “ : “ işleci, yazılan hücreler DAHİL, bunların arasındaki TÜM HÜCRELERi ifade eden HÜCRE ARALIĞI BAŞVURUSU anlamına gelir ve A7:A26 gibi kullanılır.
    • “ ; “ işleci, İLE anlamına gelmek üzere, birden çok başvuruyu bir başvuruda birleştiren BİRLEŞİM İŞLECİdir ve =TOPLA(A1:A8;B4:B25 ) şeklinde kullanılır. Örnekteki formül A1:A8 aralığı ile B4:B25 aralığındaki SAYISAL değerlerin TOPLAmını verir.
    • “ “ boşluk işleci, KESİŞİM anlamına gelir ve =TOPLA(A1:C8 B4:B20) şeklinde kullanılır ve verilen hücre aralıklarının kesişimi anlamına gelir. Örnekteki formül A1:C8 hücre aralığı ile B4:B20 hücre aralığının KESİŞİMi olan B4:B8 hücre aralığının TOPLAmını verir.
Hesaplama Öncelikleri ve İşlem Yapma Sırası

Malum olduğu üzere Excel’de formüller “ = “ (eşittir işareti) ile başlar ve formül içerisindeki işleçlere göre yapılan hesaplamaların elbette bir öncelik sıralaması vardır.
Ancak “ ( ) ” (parantez işaretleri) kullanılarak hesaplama önceliğini değiştirmek mümkündür.
  1. Öncelik sırası

    Yukarıdaki açıklanan işleçlerin birkaçı/tümü aynı formül içerisinde kullanıldığında bu hesaplamalar; eşdeğer işleçler arasındaki hesaplama önceliği SOLDAN SAĞA olmak üzere;
    1. Başvuru İşleçleri (iki nokta üst üste, tek boşluk ve noktalı virgül)
    2. Olumsuzlama (negatife çevirme) işleci ( –2 ‘deki gibi )
    3. Aritmetik işleçler (yüzde, üs, çarpma/bölme, toplama/çıkarma, karşılaştırma işleçleri)
      sırasına göre gerçekleşir.
  2. Hesaplama önceliğindeki sıralamayı değiştirme
    Yukarıda belirtilen hesaplama önceliği sırasını “ ( ) “ (parantez–ayraç işaretleri) kullanılarak değiştirmek mümkündür. Bir’den fazla parantez iç içe kullanıldığında hesaplama önceliği, en içteki parantezden en dıştakine doğru şeklindedir.

    Örneğin:
    = A1+52/TOPLA(A2:G2) formülünde; önce A2:G2 hücre aralığının toplamı alınır, sonra 52 sayısı bulunan toplama bölünür, çıkan sonuç da A1 hücresindeki değerle toplanır.

    Aynı formül =(A1+52)/TOPLA(A2:G2) şeklinde yazıldığında ise önce A2:G2 hücre aralığının toplamı ve A1 hücresindeki değer ile 25’in toplamı bulunur, en son bölme işlemi yapılır.